给定两个整型数组,本题要求找出不是两者共有的元素。
输入格式: 输入分别在两行中给出两个整型数组,每行先给出正整数N(≤20),随后是N个整数,其间以空格分隔。
输出格式: 在一行中按照数字给出的顺序输出不是两数组共有的元素,数字间以空格分隔,但行末不得有多余的空格。题目保证至少存在一个这样的数字。同一数字不重复输出。
输入样例: 10 3 -5 2 8 0 3 5 -15 9 100 11 6 4 8 2 6 -5 9 0 100 8 1 输出样例: 3 5 -15 6 4 1
list1 = list(map(int, input().split())) list2 = list(map(int, input().split())) list1.pop(0) list2.pop(0) list3 = list1+list2#合并 tmp1 = sorted(list(set(list1)))#去重排序 tmp2 = sorted(list(set(list2))) i,j=0,0 while i<len(tmp1) and j<len(tmp2):#去掉相同 if tmp1[i] < tmp2[j]: i+=1 elif tmp1[i] == tmp2[j]: while tmp1[i] in list3:#反复去掉相同 list3.remove(tmp1[i]) i+=1 j+=1 elif tmp1[i] > tmp2[j]: j+=1 tmp1=[]#避免重复的 记录已经打印的 count=0 for num in list3: if num not in tmp1: tmp1.append(num) if count>0: print(' ',end='') print(num,end='') count+=1